МАРСОХОД

Open Source Hardware Project

Альтера выпустила Quartus Prime v16

qprime16

Компания Альтера выпустила новую, 16-ю версию своего САПР Quartus Prime для ПЛИС.
Скачать можно на сайте альтеры.

Здесь, как и в предыдущей версии Quartus Prime, существует три вида квартуса: Lite Edition, Standard Edition, Pro Edition. В зависимости от типа редакции САПР поддерживает разные наборы микросхем и разный набор дополнительных возможностей. Конкретные отличия разных редакций квартусов можно посмотреть вот здесь на сайте альтеры.

Меня интересует бесплатная версия Quartus Prime Lite Edition: она поддерживает ПЛИС серии MAX II, MAX V, MAX10, Cyclone IV, Cyclone V, Arria II. Это значит, что мы сможем использовать это ПО с нашими платами Марсоход (MAX II), Марсоход2bis (Cyclone IV), Марсоход3 и Марсоход3bis (MAX10).

К сожалению, для FPGA Cyclone III и платы Марсоход2 нужно использовать отдельную версию Altera Quartus II v13.1.

Что нового в последней 16-й версии? Ну можно почитать вот здесь: https://www.altera.com/products/design-software/fpga-design/quartus-prime/what-s-new.html - как обычно обещают прирост производительности и небывалую оптимизацию. Впрочем, не уверен, что мы это заметим... Вероятно все эти улучшения становятся сильно заметными в очень сложных проектах для очень больших ПЛИС типа Stratix или Arria. Нужно будет поработать с этим квартусом какое-то время, чтобы понять, что стало лучше, удобней (или хуже)..

Я установил себе 16-ю версию, чтобы откомпилировать наш проект "моргаем светодиодами" для Марсоход3 и проверить как загружается проект в ПЛИС через наш программатор MBFTDI. Проверил - успешно откомпилировал и успешно загрузил SOF файл в плату Марсоход3. Работает.

 

Комментарии  

0 #8 WolfTheGrey 20.09.2016 09:57
А вот и сама суть проблемы:
В терминале набираю команду: ./jtagconfig
на что дает ответ: 1) USB-Blaster variant [3-1]
Unable to lock chain - Insufficient port permissions
0 #7 WolfTheGrey 20.09.2016 09:05
nckm Спасибо за наводку, нашел на портале две статьи: квартус на линуксе, и линуксовый драйвер программатора.
Я использую китайский USB-Blaster, по тихой придется новый программатор покупать.

Установлена ОС: Linux Mint 18 - она хороше встала, стабильно работает. До этого ставил Ubuntu 16.0.4 но она не прижилась из за нестабильной работы, и частого сваливания экрана в артефакты. (не совместима с моей видеокартой видать).

Фотки по крупнее:
https://yadi.sk/i/cEfQ0pYhvRHHS
https://yadi.sk/i/AeQOs4j1vRHHz
+1 #6 nckm 20.09.2016 04:17
Цитирую WolfTheGrey:
Добрый день.
А почему не работает загрузчик? Под виндовс все прошивается спокойно, Хочу освоить линукс. Скачал квартус вебку, все поставил, настроил, запустил....
И выкуси - на всех версиях одна ошибка:
Unable to scan device chain. Please check the hardware setup.
Скрин экрана: http://img.radiokot.ru/files/69385/medium/12lpyo7f82.png

Экран мутный - не понятно ничего. Это Linux? Какой? И наш новый драйвер под линукс?
0 #5 WolfTheGrey 20.09.2016 03:20
0 #4 WolfTheGrey 20.09.2016 03:19
Добрый день.
А почему не работает загрузчик? Под виндовс все прошивается спокойно, Хочу освоить линукс. Скачал квартус вебку, все поставил, настроил, запустил....
И выкуси - на всех версиях одна ошибка:
Unable to scan device chain. Please check the hardware setup.
Скрин экрана: http://img.radiokot.ru/files/69385/medium/12lpyo7f82.png
0 #3 Daniil 25.08.2016 15:25
какое то время пробовал 15 версию, а сейчас 16 для проектов среднего размера - время компиляции заметно выросло, даже простой проект кордика собирается в разы дольше чем в 14.1. только 15 еще и не стабильна
0 #2 Валера 25.08.2016 04:32
Загрузка в флеш память типа EPCS возможна в Lite Edition?
0 #1 alman 18.08.2016 15:01
Что-то давно новостей не было. Порадуйте же чем-нибудь.

Добавить комментарий


Защитный код
Обновить


GitHub YouTube Twitter
Вы здесь: Начало Статьи о разном Альтера выпустила Quartus Prime v16