МАРСОХОД

Open Source Hardware Project

Добро пожаловать, Гость
Логин: Пароль: Запомнить меня
  • Страница:
  • 1
  • 2

ТЕМА: Max II не работают проекты с ROM

Max II не работают проекты с ROM 1 год 3 мес. назад #7460

  • www_and
  • www_and аватар Автор темы
  • Не в сети
  • Новый участник
  • Новый участник
  • Сообщений: 6
  • Спасибо получено: 0
Пила находится над уровнем нуля на 1.5 вольта, размах пилы 1.5 вольт (как и прямоугольника и обратной пилы). Вместо синуса постоянный уровень 1.5 вольт. Выложу скрины проекта, осциллограммы через 1-2 дня, сейчас я на выезде на электрических испытаниях по работе.

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

Max II не работают проекты с ROM 2 нед. 6 дн. назад #7657

  • nckm
  • nckm аватар
  • Не в сети
  • Администрация форума
  • Администрация форума
  • Сообщений: 94
  • Спасибо получено: 25
Попробовал симулировать ваш код - замечательно симулируется и выдает синус.
Вот мой тестбенч:
module tb;

reg clk=0;
always
	#5 clk=~clk;
	
wire [7:0]out;

gen_256 mod(
		.clk50M(clk),
		.adder_value(10000),
		.waveform(2'b00),
		.signal_out(out)
		);
		
initial
begin
	$dumpfile("out.vcd");
	$dumpvars(0,tb);
	#10000000;
	$finish();
end

endmodule

Скриншот GtkWave во вложении. Думаю должно работать.
А не может быть, что у вас на adder_value подается очень маленькое значение, например 1 или вообще ноль, тогда на accumulator будет ноль или очень медленный рост?
Вложения:

Пожалуйста Войти или Регистрация, чтобы присоединиться к беседе.

  • Страница:
  • 1
  • 2
Время создания страницы: 0.142 секунд

ВКонтакте  facebook  GitHub  YouTube  Twitter
Вы здесь: Начало Forum Наш форум Обсуждаем Altera Quartus II Max II не работают проекты с ROM